Skip to content

Recovering files from a readable disk

Windows

Caution
This will wipe all existing data on the USB drive.
  1. Download and run Rufus.
  2. Select “ISO Image” and then browse for the ISO image.
  3. Select which flash drive you want to put the installer on.
  4. Select the Partition scheme (GPT/MBR) depending on your motherboard’s capabilities.
  5. Click “Start” and wait for it to finish.
  6. Eject the USB flash drive.

There is no need to mess with any other settings in Rufus.

macOS

  1. Open the Terminal.
  2. First, without the flash drive inserted, run diskutil list in the Terminal.
  3. Plug in the flash drive and run diskutil list again. You can do this to identify the drive device path. The device path is in the form of /dev/diskN, where N is a number (example: /dev/disk1).
  4. Unmount the flash drive you have identified. diskutil unmountdisk /dev/diskN.
  5. Convert the ISO image. hdiutil convert /path/to/image.iso -format UDRW -o /path/to/ubuntu.img
  6. Run sudo dd if=/path/to/image.img of=/dev/rdiskN status=progress to create a bootable drive from the image. Using /dev/rdiskN instead of /dev/diskN usually results in faster media creation.
  7. Wait until dd finishes. The terminal will display the next prompt when it’s done.
  8. Eject the USB flash drive: diskutil eject /dev/diskN.

Linux

  1. First, without the flash drive inserted, run lsblk in the Terminal.
  2. Plug in the flash drive and run lsblk again. You can do this to identify the drive device path. The device path is usually in the form of /dev/sdX, where X is a letter (example: /dev/sdb).
  3. Run dd if=/path/to/image.iso of=/dev/sdX status=progress to create a bootable drive from the ISO.
  4. Wait until dd finishes. The terminal will display the next prompt when it’s done.

Ventoy (Windows and Linux)

Follow our Ventoy guide to make one flash drive that can boot multiple ISO files, this is a more advanced method but suitable for power users who may not have heard about it before.

Open the File Manager from the applications menu, you should see your disk in the pane on the left. In the below image, it is the “11GB Volume”

image1

Double click the desired disk and it should open in the file manager.

image2

Once opened, you can drag and drop files to another disk that you mount into the system just like in Windows.